Training the idenprof model using Python 3.7.4 fails

Hi all,

I’ve successfully followed the car image recognition example [1] and I am now trying to run the FirstTraining.py from the idenprof example [2]. Unfortunately, I get the following output / error message when running FirstTraining.py.

Model: "model"
(removed model specifics and some lines)
Total params: 23,608,202
Trainable params: 23,555,082
Non-trainable params: 53,120

WARNING:tensorflow:`period` argument is deprecated. Please use `save_freq` to specify the frequency in number of samples seen.
Using Enhanced Data Generation
Found 9000 images belonging to 10 classes.
Found 2000 images belonging to 10 classes.
JSON Mapping for the model classes saved to  idenprof/json/model_class.json
Number of experiments (Epochs) :  200
Epoch 1/200
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/tensorflow_core/python/framework/op_def_library.py", line 527, in _apply_op_helper
    preferred_dtype=default_dtype)
  File "/usr/local/lib/python3.7/site-packages/tensorflow_core/python/framework/ops.py", line 1296, in internal_convert_to_tensor
    ret = conversion_func(value, dtype=dtype, name=name, as_ref=as_ref)
  File "/usr/local/lib/python3.7/site-packages/tensorflow_core/python/framework/constant_op.py", line 286, in _constant_tensor_conversion_function
    return constant(v, dtype=dtype, name=name)
  File "/usr/local/lib/python3.7/site-packages/tensorflow_core/python/framework/constant_op.py", line 227, in constant
    allow_broadcast=True)
  File "/usr/local/lib/python3.7/site-packages/tensorflow_core/python/framework/constant_op.py", line 265, in _constant_impl
    allow_broadcast=allow_broadcast))
  File "/usr/local/lib/python3.7/site-packages/tensorflow_core/python/framework/tensor_util.py", line 437, in make_tensor_proto
    raise ValueError("None values not supported.")
ValueError: None values not supported.

I also tried with the full trainer [3], but this failed as well.

I am using Python 3.7.4 on macOS 10.15. Please find my pip3 list below.

Your thoughts are much appreciated…!

Thanks, Mark

[1] - https://medium.com/@guymodscientist/image-prediction-with-10-lines-of-code-3266f4039c7a
[2] - https://towardsdatascience.com/train-image-recognition-ai-with-5-lines-of-code-8ed0bdd8d9ba
[3] - https://github.com/OlafenwaMoses/IdenProf/blob/master/idenprof.py

pip3 list:

Package Version


absl-py 0.8.1
astor 0.8.0
cycler 0.10.0
gast 0.2.2
google-pasta 0.1.7
grpcio 1.24.1
h5py 2.10.0
imageai 2.0.2
Keras 2.3.1
Keras-Applications 1.0.8
Keras-Preprocessing 1.1.0
kiwisolver 1.1.0
Markdown 3.1.1
matplotlib 3.1.1
numpy 1.17.2
opencv-python 4.1.1.26
opt-einsum 3.1.0
Pillow 6.2.0
pip 19.1.1
protobuf 3.10.0
pyparsing 2.4.2
python-dateutil 2.8.0
PyYAML 5.1.2
scipy 1.3.1
setuptools 41.0.1
six 1.12.0
tensorboard 2.0.0
tensorflow 2.0.0
tensorflow-estimator 2.0.0
termcolor 1.1.0
Werkzeug 0.16.0
wheel 0.33.4
wrapt 1.11.2

@markhm Tensorflow doesn’t support Python3.7 as at now. You need to downgrade to Python 3.6

Sorry for hijacking the thread, but I’m also facing the same issue.
I downgraded python to 3.6.8 it didn’t work, I downgraded again to 3.5 and it seems that the problem persist.

Im getting the same error posted above, but I’m currently on Windows 10

Edit: Downgraded TensorFlow from 2 to 1 and it seems to work. The model is currently training.

1 Like

Thanks for sharing this solution @aykwm